Created on | Updated on
フォローする

Substance Painter 2018.2 -2018.2.1 リリースノート

Substance Painter 2018.2では、従来よりもテクスチャリングを容易にするSubsurface Scatteringペインティングなど、待望の機能が追加されています。

リリース日:2018年8月2日

主要機能

Subsurface scattering

リアルタイムビューポートおよびIrayレンダラで、Subsurface scattering がサポートされるようになりました。Subsurface scattering は、物体または表面を貫通するときの光のメカニズムです。金属面のような反射の代わりに、光の一部がマテリアルにより吸収され、その後、内部で散乱します。 実際の生活の中の多くの材質は、皮膚またはワックスのようなsubsurface scatteringを有します。

我々のSubsurfaceエフェクトの実装は、他のゲームエンジンや他のオフラインレンダラのリアルタイム実装と非常によく似ています。 他のアプリケーションで使用する散乱テクスチャの作成を非常に簡単にします。

上の例は、有名なDigital Emily 2アセットの例です。 USC Institute for Creative TechnologiesとDigital Emily 2アセットを使用してレンダリングを実演できることをWikihumanプロジェクトのメンバーに感謝します。(この比較は、視覚的な違いを説明する可能性のある正確な照明条件ではなく、類似の条件で行われたことに注意してください)。

Subsurface Scatteringをプロジェクトに追加するには、以下の手順に従います。

  1. Display Settings(ディスプレイ設定)ウィンドウに移動し、Subsurface Scattering設定を有効にします。
  2. 現在のテクスチャセットに「Scattering」チャンネルを追加する
  3. ビューポートでsubsurfaceエフェクトを表示するための新しいチャンネルを白でペイントするかFillレイヤーを使用します。

より詳細な手順については、Subsurface Scattering のドキュメントを参照してください。

リアルタイムビューポートでSubsurface Scattering をサポートするには、プロジェクト内のシェーダを更新する必要があります。カスタムシェーダーについては、シェイダーAPIで何が変更されたかを知るためのヘルプメニューのドキュメントを参照してください。

塗りつぶしレイヤーのマニピュレータ

塗りつぶしレイヤコントロールが改良され、マニピュレータが提供されました。 塗りつぶし投影を正確に配置して制御する事が簡単になりました。

UV投影を使用するとマニピュレータが2Dビューに表示されます:

  • マニピュレータの外側をクリックすると、回転します。
  • 境界線の四角形をクリックすると、拡大/縮小されます。
  • マニピュレータの内部をクリックすると、移動します。
  • CTRLを使用して、シンメトリの複数のコーナーに影響を与えます。
  • SHIFTを使用して、変換(移動、回転、またはスケール)を制限します。

Tri-Planar投影を使用すると、マニピュレータが3Dビューに表示されます:

  • 点線のキューブは、グローバル投影を表します
  • W、EまたはRのキーボードショートカットを使用して、移動、回転、スケールモードを切り替えます。
  • Tキーボードショートカットを使用して、マニピュレータのローカル方向とワールド方向を切り替えます。
  • SHIFTを使用して変換を制限します。
  • Tri-Planarキューブ投影法は、高度な塗りつぶしレイヤプロパティでも変更できます。

ビューポートの上部にあるコンテキストツールバーは、現在の投影モードに応じて適応し、追加のツールとコントロールを提供します:

詳細については、Fill Layerのドキュメントを参照してください。

ステンシルおよびプロジェクションツールの非正方形および非タイリングサポート

ステンシルパラメータと投影ツールは、非正方形の解像度と非タイリングの動作をサポートするように改良されました。既定では、既定のパラメータは非タイリングに設定されています。 このパラメータは、ツールのプロパティで変更できます。

タイリングモードは次のように設定できます。

  • タイリングなし(デフォルト)
  • 水平タイル張り
  • 垂直タイル
  • HおよびVタイリング(古い動作)

この新しいパラメータは、ツールやブラシのプリセットに保存することができ、カスタムコンテンツと簡単に共有できます。

  • 投影比は、非正方形の解像度を出力するSubstanceファイルにも適応します。 比率は出力ノードから直接計算されます。
  • 投影ツールを使用すると、複数のチャンネルの比率が異なる場合、見つかった最初の比率が他のすべてのチャンネルに適用されます。

カメラのインポートと管理

Substance Painter内のカスタムカメラをメッシュインポートとともにインポートすることが可能になりました。3Dビューポートで選択したカメラを通してシーンを見ることができ、Irayでレンダリングするのに使用するカメラを選択できます。

詳細については、カメラ管理のドキュメントを参照してください。

カメラをプロジェクトに読み込むには:

  1. 同じファイル(FBX、Alembic、glTFなどのサポートされているフォーマット)内にカメラと一緒にプロジェクトのメッシュを書き出します。
  2. 新しいプロジェクトウィンドウ(またはプロジェクト構成)で[import cameras]設定を選択します。
  3. ビューポートのドロップダウンまたは表示設定の設定を使用して、目的のカメラに切り替えます。

ディスプレイ設定ウィンドウのカメラ設定が拡張され、カメラのプロパティが制御されます。
カメラ間で切り替えたり、比率を見たり、プロパティをロックしたりして、変更を避けることができます。 復元ボタンを使用して、カメラを初期値に戻すことができます。

カメラフレーム(およびそのゲート)も考慮され、特定の視点からの表示とペイントが可能です。 フレームとゲートは3Dビューポート上に表示され、不透明度は[Viewport Settings]ウィンドウの[Display Settings]で制御できます。

レイヤスタック動作の改善

  • IDマップにマテリアルとスマートマテリアルをドラッグアンドドロップ:
    シェルフからビューポートへのコンテンツのドラッグアンドドロップが改善されました。 マテリアルをドラッグアンドドロップするときにCTRLを押すと、マスクとして使用されるIDカラーを選択できるようになりました。
    レイヤースタックで作成された新しいレイヤーに、色選択エフェクトを持つ黒いマスクが追加されます。 同じマテリアルが他のIDカラーにドラッグアンドドロップされると、既存のレイヤーが更新され、IDカラーが結合されます。


  • イヤースタックドラッグ&ドロップスクロール:
    レイヤースタックの周りにレイヤーをドラッグすると、小ウィンドウが表示されるようになりました。
    レイヤースタックウィンドウの境界付近でリソースまたはレイヤーをドラッグすると、自動的にコンテンツのスクロールが開始されます。

glTFとAlembicメッシュのインポート

メッシュのインポートや新規プロジェクトの作成に新しいファイル形式がサポートされるようになりました。

  • glTF:このフォーマットは、テクスチャをエクスポートするときに既に使用できていましたが、インポートに使用できるようになりました。 glTFファイルにテクスチャが含まれている場合、一緒にインポートされ、レイヤースタック内に配置されます(メタリック/ラフネスワークフロー用)。
  • Alembic:このフォーマットは、メッシュを転送するためにVFX /アニメーション業界で広く使用されています。

Substance Painterでは、現時点でインポートするアニメーションのフレームを制御する方法はありません。
これは、Alembicファイルをエクスポートするときに、アセットのペインティングに使用される参照フレームが既に設定されている必要があることを意味します。

Substance統合の改善

待望のリクエストによりSubstance Painter内のSubstanceインテグレーションは、改善されました。

  • Visible If :「Visible if」は、条件に基づいてパラメータを非表示にするSubstanceファイル形式の優れた機能です。この機能により、より明確なパラメータとコンテキスト設定のリストが提供され、全体的により使いやすいマテリアルとフィルタが提供されます。詳細については、Substance Designerのドキュメントを参照してください。


  • Substance Presets
    Substanceプリセットは、高度な調整とマテリアルのバリエーションを提供する簡単な方法です。 Substance Sourceの多くのマテリアルにはプリセットがあるので、試してみてください!Substanceファイルに1つまたは複数のプリセットが含まれている場合、パラメータリストの新しいドロップダウンが使用可能になります。 パラメータの更新に適用するプリセットを選択します。


  • Substance AttributesSubstance
    アトリビュートがインタフェースに表示されるようになり、特定のファイルに関する情報の検索が容易になりました。アトリビュートは、プロパティウィンドウのパラメータの上またはシェルフ内のアセットを右クリックするなど、2つの異なる場所で表示できます。

新しいサンプルプロジェクト "Jade Toad"

「JadeToad」という名前の新しいサンプルプロジェクトが、Substance Painterに含まれるようになりました。 このサンプルプロジェクトでは、デフォルトで有効なSubsurface Scatteringを持ちます。
プロジェクトを検索するには、File > Open Sample... メニュー項目を使用します。

リリースノート

2018.2.1

(Released August 3, 2018)

Fixed:

  • プロジェクトのアップグレードによる subsurface scatteringシェーダパラメータの欠落

Known Issues:

  • AMD VEGA GPUでの計算フリーズ
  • Windows OS上のショートカットでのHuionタブレットの問題

2018.2

(Released August 2, 2018)

Added:

  • 概要:サマーリリース、 subsurface scatteringサポート、投影と塗りつぶしの改善、カメラのインポートと選択、Alembic / glTFサポート、IDマップのドラッグ&ドロップ、改善されたSubstanceフォーマットサポートと新しいコンテンツ
  • [SSS][Viewport][Iray] 一般的なsubsurface scattering
  • [SSS] 同期MDLとsubsurface scatteringパラメータ
  • [SSS] "Scattering"という名前の新しいグレースケールチャンネルが追加
  • [SSS][Shader Settings] subsurface scattering(スキンまたは半透明)のScattering type パラメータ
  • [SSS][Shader Settings] subsurface scatteringのためのScattering scaleパラメーター
  • [SSS][Shader Settings] subsurface scatteringのScattering color パラメータ
  • [SSS][Display Settings] subsurface scatteringのサンプル数
  • [Shader][Iray] scatteringMDLをIrayに統合
  • [Shader] リソースアップデータによるShaderのアップデート
  • [Shader] 変更ログAPIとドキュメントの更新
  • [Tool Properties][Proj] Tri-planar投影の新しいパラメータ
  • [Viewport][Proj] マニピュレータを使用して3Dビューでレイヤーのプロパティを直接制御する(Tri-planar投影)
  • [Shortcuts][Proj] Triplanar 投影マニピュレータ用の新しいショートカットQ、W、E、R、T
  • [Viewport][Proj]マニピュレータ(UV投影)を使用して2Dビューでレイヤプロパティを直接制御
  • [Shortcuts][Proj] UV投影マニピュレータの新しいショートカットQ
  • [Contextual Toolbar][Proj] triplanar 投影マニピュレータを制御する
  • [Contextual Toolbar][Proj] UV投影マニピュレータを制御
  • [Tool Properties] 投影とステンシルツールでテクスチャのタイリングを無効にする
  • [Stencil] 投影ツール/ステンシルで非正方形の画像を使用
  • [Stencil] プロパティウィンドウでタイリングモードの制御を許可
  • [Stencil] 非タイリングステンシルでズームがセンターにない
  • [Cameras] Maya、Max、Blender、Modo、DAEからカメラをインポートする
  • [Cameras][Viewport] インポートしたカメラをビューポートで選択して制御
  • [Cameras][Iray] インポートしたカメラをIrayで選択して制御
  • [Cameras][UI][New project][Project configuration] "Import cameras" は既定で有効
  • [Cameras][Shortcuts] ショートカット「<」と「>」を追加してカメラを切り替える
  • [Cameras][Viewport] ビューポートにフレームを追加
  • [Cameras][Viewport Settings] フレームの不透明度制御
  • [Cameras][Camera Settings] 最大焦点距離500mm
  • [Cameras][Camera Settings] 露出率
  • [Cameras][Camera Settings] ロックオプションを追加
  • [Cameras][Camera Settings] リストアオプションを追加
  • [Cameras][Camera Settings] フォーカス距離アトリビュートを追加
  • [glTF]glTFファイルのインポート
  • [glTF] アンビエントオクルージョンマップをインポー
  • [Alembic]スタティックジオメトリを持つAlembic 1フレームをインポート
  • [Shelf] 修飾子付きのIDマップを使用して、マテリアルをメッシュに直接ドラッグアンドドロップします(CTRL / Command)
  • [Layer Stack] IDマップを持つメッシュ上にマテリアルをドラッグ&ドロップすることで自動IDマスク作成
  • [Layer Stack] レイヤースタック全体のドラッグ&ドロップによるレイヤーの自動スクロール
  • [UI][Tool Properties] Substanceプリセットを公開
  • [UI][Help menu] ヘルプメニューの改善
  • [UI][New Project][Project Configuration] ウィンドウの再編成
  • [UI][New Project][Project Configuration]   "File"毎に"Mesh"
  • [UI][Substance] UIにSubstanceアトリビュートを表示
  • [Shortcuts] 「F4」で2Dビューと3Dビューを切り替え
  • [Shortcuts] ステンシル "N"とクイックマスク "U"を切り替えるための新しいショートカット
  • [Substance integration] Substanceパラメーターの 'visible if'ステートメントを考慮に入れる
  • [Viewport] カメラの移動後に強制的に計算されない影
  • [Content] インポートされたカメラでMeetMatを更新
  • [Content] subsurface scatteringを有効にしたサンプルを追加 - JadeToad
  • [Content] subsurface scatteringを有効にした新しいPBRプロジェクトテンプレートを追加
  • [Content] 新しいscatteringチャンネルを追加するためのエクスポートプリセットの更新
  • [Content][Shelf] pbr-metal-rough、pbr-metal-rough-alpha-test、pbrコーティング、pbr-spec-gloss
  • [Content][Shelf] 5つのスマートマテリアル(大理石とスキン)にスキャッタリングチャンネルを追加
  • [Content][Shelf] 新しいjadeマテリアル
  • [Content][Shelf] 新しいwaxマテリアル

Fixed:

  • [CMD] 異なるバージョンで同じコマンドラインを使用した異なる結果
  • [TDR] TdrLevelが設定されていると、ログにエラーがでない
  • [Baker] アンビエントオクルージョンマップが反転
  • [ID Map] 0-1の範囲外でピッキングするとクラッシュ
  • [Iray] テクスチャセットを切り替えてペイントモードに戻るときにクラッシュ
  • [Viewport] ドラッグアンドドロップのためのビューポート間のドロップ領域を同期
  • [Engine] タイリング塗りつぶしレイヤーまたは小さなブラシでペイントするとモアレアーティファクト
  • [License] ライセンスサービスのソフトウェアバージョンチェック不良
  • [License] 認証方法の再構築
  • [API] テンプレートを使用して作成する場合でも `onNewProjectCreated`スクリプトAPIイベントをコール
  • [Shader] シェーダファイルがコンパイルされないときに、コンパイルされたシェーダがキャッシュからロードされない
  • [Shelf] シェルフからHDRファイルをエクスポートすると、クランプされた値を持つファイルが出力
  • [Export] EXRエクスポートクランプは0〜1の間のRGBカラー値
  • [Content] Pプロシージャルノイズ「3D Perlin Noise Fractal」をピクセル化

Known Issues:

  • AMD VEGA GPUでの計算フリーズ
  • Windows OS上のショートカットでのHuionタブレットの問題