Created on | Updated on
フォローする

Houdini初級編:ファイル管理

Houdiniで作業中に作成する全ファイルを管理方法を理解することは、アーティストとしての成功にとって非常に重要です。典型的なシーンファイルは、ディスク上に外部依存性を持つ事があり、特にファイルを別のコンピュータに移動する場合は、これらを管理することが重要です。

Houdiniを使用する際には、定期的に使用する多数のファイル形式があります。 これらの中には、Houdiniパイプラインに固有のものもあれば、AlembicやEXRなどの業界標準なのもあります。

プロジェクトディレクトリ

Houdiniはハードドライブ全体に散らばっているファイルを扱うことができますが、作業を共有してファイルの依存関係を管理するのが難しくなります。File > New Project を使用してプロジェクトディレクトリを設定するか、File > Set Projectを使用して、既存のプロジェクトディレクトリを作業のホームベースとして選択することをお勧めします。 この作業により、必要なすべてのプロジェクトファイルに対してローカル依存関係を簡単に設定できます。

シーンファイル | .HIP

Houdiniで作業するときの主なファイルタイプは.hipファイルです。 このファイルには、すべてのノードとネットワークが含まれ、作業を保存するときに使用されるファイルタイプです。

HOUDINI DIGITAL ASSETS | .HDA

また、HoudiniネットワークをHoudini Digital Assetまたは.hdaファイルにカプセル化して保存することもできます。 アセット内のパラメータは、アセットのカスタムUIを作成するためにトップレベルにあげて表示させることができます。 これらのファイルは、他のアーティストと簡単に共有することができ、アセットがプロジェクトのライフサイクルを通じて進化するにつれ、安定したリファレンスアーキテクチャを提供します。

アセットを作成して読み込むには、アセットメニューを使用します。 また、そのメニューにあるAsset Managerを使用してシーンにロードされたアセットを管理することもできます。 シーンに同じ名前のHDAファイルが2つロードされている場合、Houdiniはマネージャーに設定されたルールに基づいてそれらのファイルの1つを選択します。 HDAファイル内のアセット定義に加えられた変更は、そのファイルを参照するシーンに自動的に変更が適用されます。 古いDigital Assetファイルは.hdaファイルと全く同じ働きをする.otl拡張子を持つことがあります。

APPRENTICE と INDIE 版のファイル

無料版Houdini ApprenticeおよびHoudini Indie製品は、Houdiniの商用バージョンでは開けない異なるファイルタイプを使用します。 Apprenticeファイルは.hipnc(非営利)を使用し、Indieは.hiplc(限定商業)を使用します。 HDAファイルと画像ファイルは同様の拡張子を持ちます。

作業のバックアップ

デフォルトでは、保存するたびにHoudiniはシーンファイルとデジタルアセットファイルの番号付きバックアップを作成します。 これにより、初期バージョンを繰り返し確認したい場合や、作業ファイルに何か問題が発生した場合に、元のファイルに戻ることが可能です。 また、編集>設定>保存と読み込みのオプションでHoudiniの自動保存設定をすることもできます。 全バックアップファイルがディスク領域を占有していることを覚えておいてください。場合によっては削除したい場合もあるかもしれません。

FILE SOP

File > Import > Geometryを使用してジオメトリをHoudiniにインポートすると、ファイルノードがジオメトリ(SOP)レベルに配置されます。 このファイルはディスク上のファイルへの接続を維持し、そのファイルに対する変更もHoudiniシーンで更新されます。 この接続を切断したい場合は、Fileノードをロックする必要があります。

FILE 依存関係 [$HIP/$JOB]

ジオメトリやテクスチャファイルなど、ディスク上のファイルを参照するノードを操作する場合、使用するパスによって、プロジェクトディレクトリを別のコンピュータまたはクラウドに移動するとどのような結果になるか決まります。つまり、ファイルを移動することで直接パスが壊れてしまうため、シーンファイルをパスの "ホームベース"として使用する$ HIPか、プロジェクトディレクトリを使用する$ JOBのどちらかを使用して保存する必要があります。Render > Preflight Sceneを使用して、シーンファイルが適切に設定されていることを確認することができます。

ディスクスペース管理

大規模なシーンファイル、バックアップファイル、大規模なシミュレーションでは、多くのディスク容量が必要です。コンピューターを不安定にするほど多くの容量を占有しないように気を付けてください。外部ドライブを使用して巨大なファイルを保存するようにして、日々の作業を達成するのに十分なスペースをコンピュータのメインディスクを残しておきます。

相互運用性

Houdiniからインポートおよびエクスポートして使用できるさまざまなファイル形式があります。 典型的なHoudiniパイプラインで扱う主なフォーマットのリストは以下となります。

Houdiniファイル - Houdiniのみで作業する.hipや.hda以外のファイル形式があります。

.bgeo - このフォーマットは、UV、速度、法線などの関連するアトリビュートとともにジオメトリを保存します。 モーションを保存するために、アニメーションとシミュレーションを番号付きbgeoファイルとして保存することができます。 bgeo.gzファイルは、この形式の圧縮されたバージョンです。

.sim - これらのファイルを使用すると、シミュレーションデータを保存して、シムをディスクにキャッシュすることができます。 このファイルを使用する人もいますし、.bgeosを使ってシムをキャッシュする人もいます。

.ifd - これは、Mantraでレンダリングするときに作成されるシーン記述形式です。 通常、このファイルはHoudiniでのレンダリング時に作成されますが、Mantraでレンダリングするためにディスクに保存することがあります。

.pic - 過去にHoudiniによって使用された画像ファイルフォーマットです。 現在はオープンソースのEXRがデフォルトフォーマットとして置き換えられました。

.rat - このイメージフォーマットは、Mantraでレンダリングするテクスチャマップに最適です。 とにかくすべてのテクスチャがこのフォーマットに変換されるので、Mplayを使用してこのフォーマットに変換すると、レンダリングの速度が向上します。

画像フォーマット - これらの業界標準フォーマットは、ショットのレンダリングやテクスチャマップのために使用されます。

.exr - OpenEXRはIndustrial Light&Magicによって開発されたハイダイナミックレンジ(HDR)画像ファイル形式で、現在、Houdiniからのレンダリングを保存するために使用されるデフォルト形式です。

.jpg/.png - この形式は、画像をWebに公開するために使用されます。

.tga/.tif - このフォーマットは、ビデオゲームのテクスチャマップによく使用されます。

ジオメトリフォーマット - ジオメトリをインポートおよびエクスポートするときに、下記形式が最も一般的です。

.abc - Alembicは、CGパイプラインにあるオープンCGグラフィックス交換フレームワークで、アプリケーション間でデータを共有します。

.fbx - オートデスクが所有するこのフォーマットは、ゲームエンジンや他の3Dアプリケーションとデータのやり取りをする際に一般的です。 ジオメトリ、リギング、モーション、シェーダの情報を保持できます。

.obj - これはもともとWavefrontによって作成された単純なジオメトリフォーマットです。

PREFLIGHTパネル

Renderメニューから、Preflight Sceneシーンを選択してシーン設定を評価します。

  1. リファレンスファイル - Preflight パネルは、シーンファイルのファイルリファレンスを検証するときに$ HIPまたは$ JOBを参照できます。
  2. 緑色でハイライトされたリファレンス - リファレンスが$ HIPまたは$ JOBのどちらかを基準にしている場合は、緑色で表示され、動作していることを示します。
  3. 誤ったリファレンス - ファイルリファレンスが$ HIPや$ JOBに関係なく、直接参照している場合は、赤で表示され、プロジェクトを他のアーティストやクラウドと共有する前に修正する必要があります。
  4. エクスプレッションの編集 - 任意のファイル名をクリックし、エクスプレッションを右クリックしてエクスプレッション編集ウィンドウを開きます。

0 コメント

記事コメントは受け付けていません。