フォローする

Linux版Mayaでフォントが読み込めないというエラーが出てしまう

■ 問題

Linux版Mayaで、以下のようなエラーがスクリプトエディタに表示されてしまいます。

// Error: Failed trying to load font : -*-helvetica-bold-r-normal-*-11-*-*-*-*-*-iso8859-1 //

■ 解決方法

フォントがなくてもMayaの操作に深刻な問題は起こりませんが、Mayaがフォントにアクセスする際に、エラーが常に表示されてしまいますので、必要なフォントパッケージをインストールしてください。

以下の4つのフォントパッケージがインストールされているかをyumコマンドで、ご確認ください。

xorg-x11-fonts-ISO8859-1-100dpi  (上記のエラー例の、helvetica-boldは、このパッケージに含まれています)
xorg-x11-fonts-ISO8859-1-75dpi
liberation-mono-fonts liberation-fonts-common
liberation-sans-fonts liberation-serif-fonts

確認するための例として、全てのパッケージの中から、”xorg-x11-fonts-ISO8859″という文字列を持ったパッケージを表示します。(例はFedora14)

yum list | grep xorg-x11-fonts-ISO8859

フォントパッケージがインストールされている場合、以下のような出力が返されます。

xorg-x11-fonts-ISO8859-1-100dpi.noarch   7.2-12.fc14        @updates
xorg-x11-fonts-ISO8859-1-75dpi.noarch    7.2-12.fc14         @updates

フォントパッケージがインストールされていない場合は、@(アットマーク)が表示されません。

xorg-x11-fonts-ISO8859-1-100dpi.noarch   7.2-12.fc14        updates
xorg-x11-fonts-ISO8859-1-75dpi.noarch    7.2-12.fc14         updates

フォントパッケージをインストールする場合、以下のコマンドを実行してください。

yum install xorg-x11-fonts-ISO8859-1-100dpi xorg-x11-fonts-ISO8859-1-75dpi liberation-mono-fonts liberation-fonts-common liberation-sans-fonts liberation-serif-fonts

0 コメント

記事コメントは受け付けていません。