フォローする

Bitmap2Material 2.1ユーザーガイド

■ 1. Overview

Bitmap2Material の Substance Filter は、迅速かつ効率的に生のビットマップと写真からす ぐに制作に使用できる マテリアルを作成するための新しい方法です。Unity3.4 及びMaya と 3ds Max バージョン 2012 にプリインストールされたすべての Substance 可能なソリュ ーションと組み合わせて使用することができます。それだけなく、Substance Player とと もにスタンドアロンツールとして起動する事も可能です。

Substance と Allegorithmic 社の他の製品のサポート、フォーラム、ニュース、その他情報 に関しては、Allegorithmic.com(英語)をご覧ください!

Bitmap2Material 2.1 は、パッケージ内に3 つのフィルタを含みます:

- Bitmap2Material_2.sbsar
- Bitmap2Material_2_NoGrunge.sbsar
- Bitmap2Material_2_RealtimeMobile.sbsar

Bitmap2Material_2.sbsar
このフィルターは、Autodesk Maya (2012 以上), 3ds max (2013 以上), Unity (3.4 以上),Substance Player、Substance Designer で使用する事が可能です。このフィルタを使用すると、 Unity ゲームのデスクトップ上とウェブプレーヤーの実行中に、またはオフラインのどちらでも単一のDiffuse からマップを生成することができます。

Bitmap2Material_2_NoGrunge.sbsar
GrungeMap 無しのBitmap2Material_2.sbsar の特別バージョンです。このフィルターはBitmap2Material_2.sbsar より高速です。Grunge Map 使用する予定がない場合は、ランタイム中でこちらを使用して下さい。3ds Max 2012 ではこちらだけを使用する事ができます。

Bitmap2Material_2_RealTimeMobile.sbsar
このフィルタは、特にUnity 4.1 以降で作成されたモバイル用ゲーム中のランタイムでマップを生成するために最適化されています。

■ Maya ユーザー

ワークフロー:
Hypershade 内の 2D Textures タブ下で Substance ノードをみつけます。

b2m1

 

Maya 2012 SAP では、Substance ノードを新しいノードエディタにて単純に“Tab”キ ーを押し、「Substance」という文字を入力、Texture モードを選択して作成することが できます。それにより place2D ノードが接続された空の Substance ノードが作成されます。

b2m2

 

Substance ノードを選択し、アトリビュートエディタ(以下 AE)内のロードアイコン 上をクリックして、Bitmap2Material.sbsar ファイルを読み込みます。

b2m3

 

ファイルノードを作成し、ビットマップテクスチャをロードし、Bitmap2Material ノードへ入力したいイメージをアトリビュートエディタの BitmapDiffuse アトリビュートへ ドラッグ&ドロップします。

b2m4

 

または、Hypershade 内で直接「dyn_Bitmap_Diffuse」というアトリビュートへ接続するかによ って Bitmap2Material へ入力として接続します。

b2m5

 

“Bitmap_ Relief” と “Bitmap_Details_Optional” インプットは必要ありません。最初に追加したものに入力として HightMap や NormalMap を使用することがで きます。これにより高さや NormalMao にディティールを追加することができます。

TreeView にて、目的の出力を選択するか、

b2m6

 

Diffuse、Specular、Normamap が接続された基本マテリアルを素早く作成するためにアトリ ビュートエディタの「Create Shader network」ボタンをクリックすることによって、シェーダーネットワークを作成できます。

b2m7

 

Substance パラメーターは、結果にを微調整を行います。各パラメーターの説明は15 ページをご確認下さい。

結果に満足した場合、「Export images to disk」ボタンをクリックすることにより、また は、ゲームエンジンが B2M をサポートしている場合、.FBX 内のメッシュとともにSubstance を埋め込むことによって、各ビットマップ・ファイル出力をベイク可能です。

b2m8

b2m9

注意:さらに、「Create shader network」機能が自動的に出力をすべてベイクし、プラグインのディレクトリパスを定義するときに Hypershade の内の同じシェーダーネットワークを再作成するをチェックすることができます。

b2m10

Preset:

Substance Player で作成された Maya Substance プリセットをロードすることができます。デフォルトで、Bitmap2Material フィルターは Maya の”attrPresets”ディレクトリ にコピーすることができる 6 個のプリセットを持っています。
Windows(x86): “¥Documents¥maya¥2012¥presets¥attrPresets¥substance”

Windows(x64): “¥Documents¥maya¥2012¥presets¥attrPresets¥substance”

MAC OS X:“/USERNAME/Library/Preferences/Autodesk/maya/2012-x64/presets/attrPresets/substance ”

Linux: “/home/USERNAME/maya/2012-x64/presets/attrPresets/substance”

注意:”substance”フォルダが存在しない場合、それはあなたがまだ Maya の Substanceプリセットを作成していないことを意味します。このフォルダを手動で作成する必要 があります。

プリセットファイルををロードするためには、Substance ノードを選択し、アトリビュ ートエディタ内の “Presets”をクリックしてください。

b2m11

 

Maya の他のシェーディングノードのように、”置き換え”または望む割合で”ブレンド”を選択することによって、現在の Substance のノードにプリセット値を適用すること ができます。

■ 3ds Max ユーザー

注意:

・3ds Max の2012 ユーザーは、フィルタの”Bitmap2Material_2.0_NoGrunge”バージョンを使用する必要があります。
・Substance input がコンパクトマテリアルエディタでサポートされていないので、新しいスレートマテリアルエディタを使用することをお勧めします。
・ Options > Preference メニューにて、「Hide Single Map Output Selectors」を有効に設定する事で、Substance の中間アウトプットを非表示にすることができます。
・ 3ds Max のGlobal Substance Settings ロールアウトにて、Preview Resolution settingはB2M で現在サポートされていませんので、解像度に影響を与えることはありません。

ワークフロー:
「標準」グループ下のマップブラウザから Substance ノードをみつけます。

b2m12

スレートキャンバスにドラッグ&ドロップし、新しいノードをダブルクリックします。

b2m13

「Substance をロード」ボタンをクリックし、Bitmap2Material.sbsar ファイルを読み込みます。

b2m14

Substace の「Bitmap_Diffuse」入力にビットマップを接続し、マテリアルの入力にすべての必要となる出力を接続します。

b2m15

“Bitmap_Secondary_Relief” と “Bitmap_Details_Optional” インプットは必要ありません。最初に追加したものに入力として HightMap や NormalMap を使用すること ができます。これにより高さや NormalMao にディティールを追加することができます。

Substance パラメータは結果を微調整することができます。

b2m16

結果に満足したら、3ds Max の「Rebder Map」機能を通して、出力をレンダーするか、 ゲームエンジンがサポートしている場合、.FBX ファイルにメッシュと一緒に Substance を埋め込むことができます。

b2m17

Presets:

Allegolithmic 社の Web サイトにて入手できる Substance Bonus Tools を通して、3dsMax 2012 のプリセットをロードできます。

b2m18

Substance ウィンドウメニューSubstance>Get from Menu を選択し、B2M を読み込みます。

b2m19

Preset Files メニューから「Add File」を使用して、プリセットを取得して使用するこ とが可能です。

b2m20

「Show all」をクリックし、Substance のプリセットを選択して、適用できます。

b2m21

■ Substance Player

注意:-Player は「presets」を保存し、Substance と互換性のあるアプリケーションすべ てで使用することができます。

ワークフロー:
player に.sbsar ファイルをドラッグ&ドロップまたは File>Open…を選択して、Bitmap2Material.sbsar を読み込みます。

b2m22

ソースとなるビットマップを 2D View (“Load in “Bitmap Diffuse”tweak を選択) にドラッグ&ドロップするか、パラメーターパネルの底部にある Bitmap Diffuse パラ メータをみつけ、テクスチャを読み込みます。

b2m23

右上のメニューで 2D ビューを分割して、一度に複数の出力をプレビューできます。

b2m24

Export メニューから任意のフォーマットで一度にすべてのテクスチャをレンダーできます。命名規則を選択、保存したい出力を選択し、Export をクリックします。

b2m25

Presets:

Player 内で、プリセットファイルを作成、読み込み、修正することができます。自分 のプリセットを追加するか Bitmap2Material と一緒に出力されたものを編集するた めに、Load File Button を使用して、ファイルを開きます。すべての使用可能なプリ セットが表示されます。

b2m26

「Add Preset to file」をクリックし、プリセットダイアログを開きます。ここで、新 しいプリセットを保存したり、削除、上書きが可能です。アイテム上でクリックし、 必要に応じて名前と説明を記述し、「Save」をクリックします。

b2m27

 

 

■ Unity 3.4

ハイエンドゲームでは:

Bitmap2Material フィルタは、標準Unity マテリアルと同様に使用することができます。既存のシェーダ上にパラメータが追加され、自動的にシェーダーテクスチャスロットへの出力を接続します。

モバイルゲームでは:

Unity 4.1 は、モバイルデバイス向けに最適化された新しいSubstance エンジンを導入しています。モバイルプラットフォーム用に設計された二次フィルター付きBitmap2Materialパッケージが付属しています。

b2m28

 

B2M Mobile は次の機能が追加されています:

・単一のDiffuse イメージからNormal, Specular、Height マップを生成します。
・自動シームレスタイリング機能
・カスタム“Shape recognition” ツールにより高品質ノーマルマップとハイトマップを生成
・ノーマルマップとハイトマップのための低周波数が標準化
・ハイライトとシャドウのキャンセルアルゴリズム
・単一のDiffuse テクスチャ上で複雑なマテリアルをシミュレートするベイクライト機能
・「Depth Balance」パラメータによりノーマルマップからハイトマップへディティールの切り替え
・色相、彩度、シャープネス、コントラストなどのDiffuse テクスチャ用測色パラメータ
・256 から2048 へのダイナミック解像度
・通常のB2M より10 倍早い

■ Unreal Engine3/UDK Users

Bitmap2Material フィルタはUDK 内の全てのSubstance ファイルと同じ方法で使用されています。UDK へB2M をインポートする と、”Substance Instance Factory” と”“Substance Graph Instance”と呼ばれる2 つのノードと一緒に使用可能なすべてのアウトプットは以下のようにコンテンツブラウザに表示されます:

b2m29

“Substance Graph Instance”ノード(黄色ノード)をダブルクリックし、入力イメージスロット表示する新しいウィンドウがポップアップします。マテリアルをカスタマイズするためにパラメーターを変更します。

b2m30

 

 

■ パラメーターガイド

Globalカテゴリ

Random Seed
スプラットのタイリング方式を使用した場合、パッチの位置をランダム化します。

MakeItTile Method
シームレスなテクスチャタイルを作り、異なる3 つの設定を選択できます。(オフセット、スプラット、タイリングなし)

Offset Tiling
オフセットタイルメソッドを使用している場合、タイルのオプションを設定します。

Offset Tiling Precision
元の画像とオフセットされた領域間の変化をどのぐらいシャープにするかを設定します。

Splat Angle Random
スプラットのタイリング方式を使用している場合、それぞれのテクスチャパッチの角度をランダム化します。

Depth Balance
ハイトマップバンプの内側または外側を歪めます。

DIFFUSEカテゴリ

Sharpen
Sharpen ディフューズ出力をシャープにします。

Color Neutralize
多くの中間色を得るためにディフューズカラーを修正します。

Hue
ディフューズマップの色相を変更します。

Saturation
ディフューズマップの彩度を変更します。

Brightness
ディフューズマップの明るさを変更します。

Contrast
ディフューズマップのコントラストを変更します。


RELIEFカテゴリ

Output Normal Format
DirectX とOpenGL 間でのノーマルマップフォーマットを選択します。

Secondary Relief Type
二次入力がハイトマップまたはノーマルマップかどうかの設定をします。

Secondary Relief Normal Format
二次レリーフマップのフォーマットを設定します。

Secondary Relief Blending
二次レリーフ入力のブレンドモードを設定します。

Secondary Relief Intensity
二次レリーフマップの強さを設定します。

Normal Strength
ノーマルマップ出力の強さを制御します。

Relief Equalizer
レリーフマップに応じてノーマルマップとハイトマップを「スムース/シャープ」にします。

Pinch Intensity
ハイトマップとノーマルマップのエッジをシャープにします。

Normal Sharpen
ノーマルマップとハイトマップをシャープにします。

Normal Soften
ノーマルマップとハイトマップをぼかします。

Height Map Balance
テッセレーションレートの機能で、ハイトマップからDisplacememnt とNormal/Bump マップへの配分データ。


SHAPE RECOGNITIONカテゴリ

Recognition Intensity
既存のノーマルマップの上に低周波形状を作成し、デプスを追加します。これはノーマルマップ出力だけに影響します。

Recognition Angle
形状認識のエフェクトを駆動する優性角度を設定します。より良い結果を得るために、テクスチャの照明方向を設定します。

Normal Shape Recognition
ノーマルマップに形状認識を適用します。

Height Shape Recognition
ハイトマップに形状認識を適用します。

AO Shape Recognition
AO マップに形状認識を適用します。


SPECULARカテゴリ

Specular Diffuse Influence
ディフューズカラーと輝度がスペキュラー出力にどのように影響するかを設定します。

Specular Saturation
スペキュラー出力の彩度を調整します。

Specular Sharpen
スペキュラー出力をシャープにします。

Specular Levels In & Out
スペキュラーマップのレベルを制御します。


Ambient Occulusiomカテゴリ

AO Multiply
ディフューズ出力にアンビエントオクルージョン をブレンドします。

AO Spread
アンビエントオクルージョンの拡散距離を設定します。

AO Light Strenght
AO をディレクショナルライトからの影に変換する仮想ライトを設定します。

AO Light Distance
仮想ライトの距離を設定します。

AO Light Angle
仮想ライトの方向を設定します。


CURVATUREカテゴリ

Curvature in diffuse
曲率データとディフューズのエッジをシャープにします。

Curvature denoise
曲率データからノイズやディティールを削除します。


LIGHTINGカテゴリ

Light Equalizer
テクスチャの低周波輝度変化を極力同じにします。

Highlights Cancel
ディフューズマップ上のハイライトを柔らかくします。

Shadows Cancel
ディフューズマップ上の暗い影の明るさを増やします。

Diffuse to albedo
テクスチャからライティング情報を削除します。


GRUNGEカテゴリ

Grunge Input
埋め込まれたグランジ(汚し)マップからディティールを追加。

Grunge Map Balance
グランジ(汚し)マップの明るい部分と暗い部分のトーンバランスを設定します。

Grunge Map Contrast
グランジ(汚し)マップのコントラストを変更します。

Grunge Map Invert
グランジ(汚し)マップの輝度を反転。

Grunge Diffuse Opacity
グランジ(汚し)マップとディフューズマップとのブレンドを設定します。

Grunge Blending Mode Diffuse
ディフューズマップとグランジ(汚し)マップとのブレンドモードを設定します。

Grunge Blending Mode Specular
スペキュラー反射マップとグランジ(汚し)マップとのブレンドモードを設定します。

Grunge Blending Mode Relief
ハイト/ノーマルマップとグランジ(汚し)マップとのブレンドモードを設定します。

Grunge Shadows in Diffuse
グランジ(汚し)マップからディフューズマップに影を追加します。


DETAILSカテゴリ

Details Input Intensity
ハイトマップとノーマルマップ上で高周波を追加するディティール入力の強さを設定します。

Details Input Tiling
ハイト、バンプ、ディスプレイスメントとノーマルマップのエッジをシャープにします。

 

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
他にご質問がございましたら、リクエストを送信してください

0 コメント

記事コメントは受け付けていません。